DHCP Relay là gì và cấu hình DHCP Relay như thế nào ?

11/01/2016

Chắc hẳn ai trong số chúng ta đều đã từng nghe ít nhất một lần về DHCP và DHCP Relay. Nhưng bạn có biết chúng là gì, và nguyên tắc hoạt động của chúng ra sao không? Trong nội dung bài viết dưới đây, VDO sẽ giúp bạn giải đáp thắc mắc này một cách chi tiết nhất.

Trong bài viết trước, VDO đã giới thiệu đến bạn một bài viết khá chi tiết về khái niệm DPCH là gì, DHCP Server là gì. Ở bài viết này, chúng tôi sẽ tiếp tục chia sẻ với bạn đọc một nội dung cùng chủ đề, đó là DHCP Relay và cấu hình của chúng.

DHCP Relay là gì ?

DHCP relay agent là gì ?

DHCP relay agent là gì ?

DHCP Relay Agent là một cấu hình được đặt cho máy tính hoặc một Router tiếp nhận các thông tin yêu cầu cấp phát IP của clients và chuyển các thông tin này đến DHCP server

Tại sao phải sử dụng DHCP Relay Agent ?

Khi giữa Clients và DHCP server có nhiều mạng khác tương ứng với nhiều router khác thì cần phải cấu hình DHCP Relay Agent vì Clients sử dụng địa chỉ broadcast để quảng bá yêu cầu cấp phát IP, khi gói tin gửi bằng broadcast đến Router thì sẽ bị loại bỏ, do vậy phải có cách để cho các router trung gian chấp nhập những gói tin broadcast này và gửi đến DHCP server, cách này chính là DHCP Relay Agent.

Ưu diểm của DHCP Relay

DHCP Raley mang lại khá nhiều lợi ích cho người dùng như:

– Phù hợp với các máy tính thường xuyên di chuyển giữa các lớp mạng.

– Kết hợp với hệ thống mạng không dây ( Wireless) cung cấp tại các điểm – Hotspot như: nhà ga, sân bay, khách sạn, trường học.

– Thuận tiện cho việc mở rộng hệ thống mạng.

Với những ưu điểm vượt trội DHCP mang lại, người dùng phải cấu hình DHCP Relay như thế nào để có thể sử dụng chúng một cách dễ dàng nhất? Không để các bạn phải đợi lâu nữa, hãy cùng VDO tìm hiểu ngay sau đây.

Hướng dẫn cấu hình DHCP Relay chi tiết nhất

Thông thường, một cấu hình DHCP Relay chi tiết sẽ được hiển thị như sau:

Mô hình LAB cụ thể

Mô hình bao gồm 2 Router Host1, Host2 dùng làm tương tự như PC, cấu hình DHCP trên Router DHCP và DHCP relay agent  trên 2 Router giữa để cấp phát địa chỉ IP động cho 2 cổng f0/0 của Host1 và Host2.

Và sau đây, chúng ta cùng đi vào thực hiện!

Các  bước cấu hình DHCP Relay

– Đầu tiên đặt IP cho các Router như mô hình LAB, đối với cổng f0/0 của Host1 và Host2 thì bạn vào interface f0/0 gõ câu lệnh là: ip address dhcp để cho cổng nhận ip từ DHCP.

– Sau khi cấu hình IP xong các bạn thực hiện việc định tuyến giữa các Router cho chúng thấy các mạng của nhau để gửi các thông tin yêu cầu hoặc cấp phát IP, ở bài này mình sử dụng static route, sau khi các bạn biết thêm về các giao thức định tuyến động mà mình hướng dẫn ở những bài sau, các bạn có thể làm lại bài lab này với giao thức định tuyến như RIP, OSPF…

Trên Router Host1 và Host2 không cần cấu hình định tuyến vì chúng ta đang chúng chỉ là các PC thôi nha.

Trên DHCPRelayAgent1:

ip route 10.0.0.0 255.0.0.0 f0/1

Trên DHCPRelayAgent2:

ip route 192.168.1.0 255.255.255.0 f0/0

Trên DHCP:

ip route 192.168.1.0 255.255.255.0 f0/0

ip route 172.16.0.0 255.255.0.0 f0/0

– Cấu hình DHCP trên router DHCP:

ip dhcp pool DHCP

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

Địa chỉ 192.168.1.1 là gateway của mạng cần cấp IP. Do không cần DNS nên không cấu hình

-Cấu hình DHCP relay agent trên 2 Router giữa:

Trên DHCPRelayAgent1:

vào interface f0/0, gõ lệnh ip helper-address 10.0.0.2

Trên DHCPRelayAgent2:

vào interface f0/0, gõ lệnh ip helper-address 10.0.0.2

Phân tích: Thông tin yêu cầu cấp IP từ Host1 Host2 gửi tới cổng f0/0 của DHCPRelayAgent1, IP 10.0.0.2 chính là địa chỉ đi đến DHCP. Sau đó gói tin được chuyển tới f0/0 của DHCPRelayAgent2 và thực hiện tương tự.

Thao tác chuẩn bị trước khi cài đặt và cấu hình DHCP Relay Agent trên windows server 2008

Để cấu hình thành công DHCP Relay Agent trên Windows server 2008, bạn cần chuẩn bị những yêu cầu sau:

– 1 máy Windows Server 2008 tên HT-DC đã nâng cấp lên Domain Controller với domain hoangthongit. Trên máy đã cài đặt dịch vụ DHCP và tạo 2 scope, 1 scope 192.168.2.10-192.168.2.100/24 và scope thứ 2 có giải mạng: 192.168.3.10-192.168.3.100 /24. Scope 2 này sẽ cấp cho giải mạng không cùng với giải mạng với HT-DC. Để xem cách cấu hình DHCP vào tạo sccop các bạn xem bài Cài đặt và cấu hình DHCP.

– 1 máy Windows Server 2008 tên HT-SRV-01, không cần Join domain. Trên máy này sẽ cài đặt DHCP Relay Agent.

– 1 máy Windows 7 tên client kiểm tra hoạt động của DHCP Relay Agent.

Mô hình DHCP Relay Agent

Mô hình DHCP Relay Agent

Và sau đây sẽ là các bước cấu hình địa chỉ mạng chi tiết:

–  Máy HT-DC có 1 card mạng nối với máy HT-SRV-01 (chế độ vmnet 2 trên phần mềm vmeware)

cài đặt DHCP Relay Agent trên windows 2008

– Máy HT-SRV-01 có 2 card mạng.

– Card Int nối với máy HT-DC có IP như sau (chế độ vmnet 2 trên phần mềm vmware):

cài đặt DHCP Relay Agent trên windows 2008

Card Ext nối với Client có IP như sau (chế độ vmnet 3 trên phần mềm vmware):

cài đặt DHCP Relay Agent trên windows 2008

Máy Client có 1 card mạng nối với card Ext của máy HT-SRV-01, địa chỉ IP để nhận auto (chế độ vmnet 3 trên phần mềm vmware).

cài đặt DHCP Relay Agent trên windows 2008

Chi tiết các bước Cấu hình dịch vụ DHCP Relay Agent trên windows server 2008

Phần 1: Cấu hình dịch DHCP và tạo các scope

Phần này mình đã hướng dẫn ở bài lab Cài đặt DHCP trước nên mình sẽ không hướng dẫn lại.

Phần 2: Cài đặt và cấu hình dịch DHCP Relay Agent.

Để triển khai dịch vụ DHCP Relay Agent, đầu tiên phải cài đặt Routing And Remote Access. (Mình sẽ giới thiệu loạt bài về dịch vụ này sau.)
Cài đặt Routing And Remote Access: Thực hiện trên máy HT-SRV-01

cài đặt DHCP Relay Agent trên windows 2008

Trên cửa sổ Before You Begin click Next.

cài đặt DHCP Relay Agent trên windows 2008

Trên cửa sổ Select Server Roles tick chọn Network Policy and Access Services.

cài đặt DHCP Relay Agent trên windows 2008

Trên cửa sổ Network Policy and Access Services click Next.

cài đặt DHCP Relay Agent trên windows 2008

Trên cửa sổ Select Role Services tick chọn dịch vụ Routing and Remote Access Service sau đó click Next.

cài đặt DHCP Relay Agent trên windows 2008

Click Install để cài đặt.

cài đặt DHCP Relay Agent trên windows 2008

Sau khi quá trình cài đặt thành công click Close.

cài đặt DHCP Relay Agent trên windows 2008

Cấu hình dịch vụ DHCP Relay Agent.

Hãy tiếp tục nhé các nhà Quản trị mạng.

Vào Start = > Administrative Tools = > chọn Routing and Remote Access

Trên giao diện RRAS click chuột phải vào HT-SRV-01(local) chọn Configure and Enable Routing and Remote Access.

Cấu hình DHCP Relay Agent trên windows 2008

Trên màn hình Welcome to the Routing and Remote Access Server Setup Wizard chọn Next

Cấu hình DHCP Relay Agent trên windows 2008

Trên màn hình Configuration chọn Custom configuration sau click Next.

Cấu hình DHCP Relay Agent trên windows 2008

Trên màn hình Custom configuration chọn LAN Routing sau đó chọn Next.

Cấu hình DHCP Relay Agent trên windows 2008

Click Finish

Cấu hình DHCP Relay Agent trên windows 2008

Click Start Service để start dịch vụ RRAS

Cấu hình DHCP Relay Agent trên windows 2008

Click mở rộng theo đường dẫn vào General trong IP v4, Click chuột phải vào Genegral chọn New Routing Protocol

Cấu hình DHCP Relay Agent trên windows 2008

Trên cửa sổ New Routing Protocol chọn giao thức DHCP Relay Agent

Cấu hình DHCP Relay Agent trên windows 2008

Click chuột vào DHCP Relay Agent chọn New Interface…

Cấu hình DHCP Relay Agent trên windows 2008

Trên màn hình New Interface for DHCP Relay Agent chọn Card Ext, tức là card nối với Client sau đó click OK 2 lần.

Cấu hình DHCP Relay Agent trên windows 2008

Click chuột phải vào DHCP Relay Agent chọn Properties

Cấu hình DHCP Relay Agent trên windows 2008

Gán địa chỉ IP của máy DHCP Server sau đó chọn Add và click OK để kết thúc.

Cấu hình DHCP Relay Agent trên windows 2008

Cấu hình máy trạm nhận IP động: Thực hiện trên máy client.

Sử dụng câu lệnh Ipconfig /renew để xin IP từ DHCP Server. Lúc này máy trạm sẽ nhận được địa chỉ 192.168.3.10, địa chỉ đầu tiên trong giải mạng của scope đã tạo trên DHCP Server.

cài đặt DHCP Relay Agent trên windows 2008

Qua nội dung bài viết trên, bạn đọc đã biết DHCP Relay là gì và cấu hình DHCP Relay như thế nào chưa? Hy vọng với những thông tin hữu ích trên, sẽ giúp bạn cập nhật thêm những kiến thức bổ ích. Và đừng quên theo dõi chúng tôi trong những bài viết tiếp theo để cập nhật thêm tin tức hữu ích cũng như những kiến thức về các dịch vụ thuê chỗ đặt máy chủ, thuê máy chủ ảo, thuê VPS, thuê trung tâm xử lý dữ liệu,… chuyên nghiệp, chất lượng, an toàn và bảo mật cao. Chúc bạn thành công!

>> Các câu hỏi liên quan : 

dhcp relay,

dhcp relay agent,

dhcp relay agent là gì,

cấu hình dhcp relay agent,

ip helper là gì,

ip helper-address là gì,

lenh ip helper address,

cấu hình dhcp relay agent trên router cisco,

cấu hình dhcp trên router,

dhcp relay agent windows server 2008,

cấu hình dhcp server 2008,

DHCP Relay là gì và cấu hình DHCP Relay như thế nào ?
5 (100%) 1 vote

About admin

Thanh Hồng là một hot blogger công nghệ của VDO. Cô đã có 5 năm kinh nghiệm làm việc tại phòng Marketting và Sale tại VDO. Cô sở hữu rất nhiều website và blog liên quan đến công nghệ, dịch vụ máy chủ, sản phẩm worktion, phần mềm bản quyền,…Cô đã cố gắng học hỏi, tích lũy và truyền đạt hết những kinh nghiệm đó trong các bài viết chia sẻ của mình. Blog của Thanh Hồng là một trong những nguồn thông tin tốt nhất giúp bạn lựa chọn được một sản phẩm, dịch vụ công nghệ hoàn hảo. Đặc biệt vì đam mê tìm hiểu về công nghệ nên cô đã dành rất nhiều thời gian đi cập nhật các tin tức công nghệ mới, các giải pháp mới, hoàn hảo nhất phù hợp cho nhiều mô hình doanh nghiệp và chia sẻ chúng theo quan điểm thú vị của riêng mình.

Hotline tư vấn miễn phí